Rationale

The API version used by your metadata is specified using the latest (or a sufficiently recent) version of the API is generally a best practice to leverage the most recent features and reduce the risk of bugs.

Scope

  • Metadata files

Best practices

  • Align your team to a recent enough version of the API to leverage most recent additions to the platform
  • Be aware that LockerService is mandatory starting from API version 40.0, we suggest to use at least this version as a default.
Did this answer your question?